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Ul Development
Fundamentals

This presentation is available on support.touchgfx.com

This presentation focus on the fundamentals elements when creating Ul

application with TouchGFX.

Starting out by looking software architectural concepts, the is used within
TouchGFX, then talking a bout the Designer and widgets,

End finally looking at how to ingrate you own C++ code in an application.

This presentation primarily targets software developers with a basic skill-set
within C++ and embedded GUI development on STM32.

Since this is a fundamentals video, newcomers to this filed, can also benefit
from watching this presentation, but a basic understanding of what TouchGFX
is, is advised.

This can for example be achieved by watching the presentations:
TouchGFX Introduction
(https://support.touchgfx.com/docs/resources/presentations#touchgfx-
introduction), and

TouchGFX Technical Introduction
(https://support.touchgfx.com/docs/resources/presentations#touchgfx-
technical-introduction)




To have a better general understating of embedded graphics it can also be
helpful to watch:

Embedded Graphics - Basic Concepts
(https://support.touchgfx.com/docs/resources/presentations#embedded-
graphics---basic-concepts)

A step-by-step guide for getting stared with TouchGFX is also available as the
workshop:

Ul Development - Getting Started
(https://support.touchgfx.com/docs/resources/presentations#ui-development---
getting-started)

The main chapter covered in this presentation are
Ul Development (https://support.touchgfx.com/docs/development/ui-
development/ui-development-introduction)

This presentation takes approximately ~ 1 hour
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Introduction

With this presentation, you get a fundamental knowledge
about TouchGFX Ul Development. You will learn:

» The basics of the software architecture
» Getting started working with the Designer and its Ul components
» Discovering TouchGFX Engine features




Introduction

Further reading
*Go to the TouchGFX documentation site :

http://support.touchgfx.com/

+Slides in this workshop will refer to relevant documentation pages. Links will be in
the lower corner of the slides

A good place to start reading following this workshop is:

Ul Development Introduction

&y




Introduction

TouchGFX Development

- TouchGFX
Main components: Ul Application
Main activities:
Development

In this presentation, we will focus on the Ul development activity

We go deeper into the different activities in the other presentations

S7i
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Documentation Link: Development Introduction 5







* Model-View-Presenter (MVP)
* View
* Model
* Presenter

Backend System

» Benefits
» Separation
* Unit testing
» Decoupled code

Backend Module

Software architecture

TouchGFX Ul

Presenter

Model User
Changed Event
Update Update
Model ul
Model

External
Event

Event

Documentation Link: Model-View-Presenter Design Pattern
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Model-View-Presenter Design Pattern

View: Handles the ui elements

Presenter: Hnadles the buisness logic behind the Ul elements
Model: Stores information through out the application and handle

communication with the rest of the system




Software architecture

* View
» Creation of Ul elements
* Ul element manipulation
* “Reception” of user input

» Sending of user input to
Presenter

» Update of Ul based on data from
Presenter

Backend System TouchGFX Ul

Lys

lite.augmented

Documentation Link: Model-View-Presenter Design Pattern 8




Software architecture

e Presenter

» Mediator between Model and
View
* Receives data from the Model
and prepares it for the View

* Receives input from the View
and sends it to the Model
. ; ; Model u
Business logic for Ul el e - o
late ate
« No knowledge about Ul - Model Ul

B o

Backend System TouchGFX Ul

‘,’ Documentation Link: Model-View-Presenter Design Pattern
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* Model

e Communicates with the
backend

» Stores data
« Passes data to the Presenter

Lys
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Backend System

Software architecture

TouchGFX Ul

External
Event

Model 9 -
Changed Evant
Update pdate
Model .

_
e

ul
Event

Documentation Link: Model-View-Presenter Design Pattern
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« MVP — Example

* When update is pressed, a get time request
is sent to the Model via the Presenter

¢ The Model sends time data to the Presenter

¢ The Presenter converts the data into

something the Clock widget can use and
sends it to the View

* The View updates the Clocks with the new
data

Software architecture

VUpdate Clock

Documentation Link: Model-View-Presenter Design Pattern

11
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* The Screen Concept

 Application consists of a number of
“Screens”

 Logical grouping of Ul and Ul logic

* One View class and one Presenter class
* One active screen at the time

* Minimizes the amount of RAM-memory

Lys
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Software architecture

Screen 3

-

Screen 1

C rasm 9
Screen 2
J\

ul

Update

View

Presenter

User
Event

Event

/

Update
Model

Model
Changed

lllustration of the screen concept with screen 1 as the active screen

Documentation Link: The Screen Concept
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» Screen Concept: Example

* When selecting clock mode, in the
“settings” screen, the selected mode is
stored in the model

» When pressing update, the Clock also
retrieves the clock mode from the model

Software architecture

Documentation Link: The Screen Concept

13
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Software architecture

» Generated Code vs. User
Code
* Engine
* Provided by TouchGFX
» Generated

* Generated by the Designer
multiple times

» Code for the widgets added in
the Designer

» Regenerated often

« User
» Generated by the Designer once
» Created for handwritten code

‘,, Documentation Link: Code Structure 14
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Software architecture I

: The Designer

‘Y’ Documentation Link: Code Structure
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This example shows the relations between Generated Code and User Code.

In the example we create an application with a rotating circle.

In this slide the circle is added to the application through the designer.

15



Software architecture

* Rotating Circle Example: The generated code

K” Documentation Link: Code Structure 16
1if
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In this slide we can see the base view for the rotating circle example.

This is the ScreenBaseView.cpp, in this file the code for adding and setting up
the circle, that we added in in designer are generated.

Since this file consists of generated code, the file is a read-only file, and are
regenerated when you select to run the demo on either simulator or target, or
generate code is selected.

16



Software architecture I

* Rotating Circle Example: The User Code

K” Documentation Link: Code Structure 17
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In this slide we can see the view for the rotating circle example.
This is the ScreenView.cpp, which are designed to be where user code should

be inserted.
Since the ScreenView are inherited from the ScreenBaseView, we are able to

access the widgets that have been added in the designer and generated code
for in the ScreenBaseView.

17



Software architecture I

* Rotating Circle Example: The Demo

Kyl Documentation Link: Code Structure 18
life.augmented

This slide shows the demo running in the Simulator



Touchgfx designer is the main tool used in the Ul development activity. With this tool
users will setup, design and create the looks of the project



Widgets

A Widget is an abstract definition of
something that can be drawn on the
screen and be interacted with 3 suttonEsample S x

* Numerous standard widgets available

» Customizable from Designer and Code -

» The adding order determines the display
order

. POSSible tO Create CUStom W|dgets A Button widget with an Image widget as a background

S7i
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Documentation Link: Widgets 20

A Widget is an abstract definition of something that can be drawn on the
screen and be interacted with. Multiple widgets, like buttons, images or graphs
are available.

Users can add widgets to their Ul and customize them with the supplied
properties. The order in which they are added determines the order in which
they are displayed.

The TouchGFX generated code for the widgets can be used as a source of
inspiration or as base by users to create custom widgets.

Custom Widget documentation link :
https://support.touchgfx.com/docs/development/ui-development/touchgfx-
engine-features/custom-widgets/

20



A Container is a component that contains child
nodes

» Children can be widgets or other containers

» Position of widgets defined relatively to the parents

» Widgets are added to a container by
dragging widgets into the container in the
tree view

» Containers act as viewports

* Only the parts of the children that intersect with the
geometry of the container are visible

Containers

A container acting as a view port

Documentation Link: Containers

21

Containers are components containing child nodes, which can be widgets or
other containers. Within TouchGFX Designer, the childs are added to a
container by dragging them within the container in the tree view. Containers
can be used for many things, for example moving multiple elements at a time
since the positions of the child elements are relative to the parent container. As
shown in the gif, elements within a container will be displayed if their

coordonates match its display window.

21



Simulator

TouchGFX includes a simulator for Ul
testing

» Building and running on target can be
time-consuming

* You can run the simulator in 3 ways
by use of:
* TouchGFX Designer
* TouchGFX Environment
* Visual Studio

Launching the simulator from TouchGFX Designer

» Option to create User code that
only runs when using the simulator
Ays

Documentation Link: Simulator 22
ife.augmented

TouchGFX includes a simulator to replicate the running Ul prototype instead of
flashing on target a project every time. This can also be used for projects
without hardware configured yet.

There are two ways to run the simulator:
Using TouchGFX Designer
Using TouchGFX Environment

For testings, It is possible to create User code that will be only ran when using
the simulator




Compiling I

A TouchGFX application can be compiled for the PC simulator or for the target
hardware

» PC simulator: Projects compiled using GCC or Visual Studio

» Hardware target: Projects compiled with the active toolchain
 Active toolchain set in CubeMX

KY’ Documentation Link: Compiling
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Projects are compiled using GCC or Visual studio, or using the toolchain of
your choice (Keil uVision, IAR Embedded Workbench, STM32CubelDE).

Be aware that the initial active toolchain is STM32CubelDe. Another toolchain
can be set within the CubeMX tool.

Using IDES with TouchGFX documentation link :
https://support.touchgfx.com/docs/4.14/development/ui-development/working-

with-touchgfx/using-ides-with-touchgfx

23



Flashing

Flashing projects on STM32-based boards can be done with different toolchains.

 Building generates a binary (.hex or .elf)
* Flash with STlink or STM32Cube Programmer

* Running on target is done using GCC
« Command can be overridden in configurations

KY’ Documentation Link: Flashing 24

life.caugmented

Building a project generates a binary file which is flashed on target using
STM32CubeProgrammer or STlink for older projects

GCC is used as default to Run a project on target from TouchGFX

Designer. The generating and running commands can be overwritten by users.
Download link for CubeProgrammer and ST-LINK Utility:
https://support.touchgfx.com/docs/introduction/installation#installing-
stm32cubeprogrammer

24



Debugging

A TouchGFX project is a set of C++ files generated by TouchGFX Designer,
TouchGFX Generator and written by developers

« Can be debugged as any other C++ application

» Target debugging with an IDE
» Performance testing

» Simulator Debugging
» Faster process than on target

» Using the DebugPrinter
» Prints debug messages on the display

S7i
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Documentation Link: Debugging 25

A TouchGFX project is a C++ project, meaning it can be debugged as any
regular C++ project.

Debugging by running on target is useful for performance testing such as
the animation speed, update frequency and responsiveness of the Ul elements.
Debugging with the simulator is much faster and more efficient for testing the look
and logic of the UI.

The DebugPrinter option will print information on the display.

25



Getting started

Using Ul templates is a good way to start a project or to understand how to work
with widgets and TouchGFX

» Widget showcasing

» Complete demos

» Can be used as source of inspiration

Online applications are out-of-the box applications dedicated to an ST evaluation kit
* More complex than Ul templates
» Explore different features of the TouchGFX framework
« Can include sample integration with hardware

K” Documentation Link: Examples 26
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TouchGFX Designer offers multiple Ul templates which showcases the
functionalities of widgets and the options of Designer. The code for those
examples and demos can be used as a source of inspiration to get started with
a custom project. Some ST evaluation kits also have dedicated demos, called
Online application which can explore advanced concepts and features.

26






Startup Window

This is where new projects can be
Conﬁgured and Created Create New Application Recent Applications
(-]
 Possibility to work with the Simulator or & g
with an Application or Ul template g o|
v wer ©
B =~ B B (-]
= [ soveanme °
[ s °
Startup window when opening TouchGFX Designer
Ky’ Documentation Link: Startup Window 28

This is where new projects can be configured and created:
Application name
Application directory path
Width,Height and Color depth

Application templates for ST evaluation kits and Ul templates can be selected.
Online applications directly combine an AT and a Ul demo

Perfect for understanding how to work with TouchGFX Designer

This can be a useful source of inspiration for user code

Online applications are out-of-the box applications for specific hardware
solutions

28



Startup Window

This is where new projects can be ppre— p—
configured and created

Recent Applications

 Possibility to work with the Simulator or o
with an Application or Ul template = E

Startup window when opening TouchGFX Designer

‘YI Documentation Link: Startup Window
ife.
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Main Window

Contains a Navigation Bar, Command

Buttons, Notification Bar, and a Detailed [ v
log g

+ Navigation bar
» Canvas: drag and drop application building
* Images: management of images used
» Text: management of text and typographies
» Config: configuration of project settings

The main window options

Documentation Link: Main Window 30

After creating a project from the startup window, users can start developing the
Ul. But lets first go through the tabs and options. The Main Window consists of
a Navigation Bar, Command Buttons, Notification Bar, and a Detailed log

In TouchGFX Designer, the navigation is done through the Navigation Bar. It
consists of:

Canvas for drag and drop application building

Images for management of images used

Text for management of text and typographies

Config for configuration of various project settings

30



Main Window

Contains a Navigation Bar, Command

Buttons, Notification Bar, and a Detailed [ v
log _

+ Navigation bar
» Canvas: drag and drop application building
* Images: management of images used
» Text: management of text and typographies
» Config: configuration of project settings

The main window options

7

Documentation Link: Main Window 31
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The Main Window consists of a Navigation Bar, Command Buttons,
Notification Bar, and a Detailed log

In TouchGFX Designer, the navigation is done through the Navigation Bar. It
consists of:

Canvas for drag and drop application building

Images for management of images used

Text for management of text and typographies

Config for configuration of various project settings

31



Main Window

* Project can be run on target or on PC
simulator

» Both commands trigger assets, code
generation and compiling

+ Key shortcuts are respectively “F5” and “F6”

 Notification bar and Detailed log are at
the bottom of the Main Window
» Shows status of running command
* Opens log of last command
» Can be toggled with keys “Alt” + “L”

Running and generating code commands, Navigation bar and Browser Code positions

KYI Documentation Link: Main Window 32
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The code for the Ul can be generated by pressing the command "generate
code" or with the key F7. from Designer it is possible to run the simulator or
flash projects on the boards using the dedicated buttons or by pressing
respectively F5 or F6.

The status of a running command is shown in the notification bar. Clicking on it
opens a detailed log to have more information on what went right or wrong.

32



Main Window

* Project can be run on target or on PC
simulator

» Both commands trigger assets, code
generation and compiling

+ Key shortcuts are respectively “F5” and “F6”

 Notification bar and Detailed log are at
the bottom of the Main Window
» Shows status of running command
* Opens log of last command
» Can be toggled with keys “Alt” + “L”

Running and generating code commands, Navigation bar and Browser Code positions

KYI Documentation Link: Main Window 33
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Pressing on the Notification Bar opens a window showing the full log of the last
command. It can also be toggled with Alt + L

33



File Menu

Consists of a File, Edit and Help menu
items

i FI |e Menu Used for File menu item in File Menu Edit menu item in File Menu
creating/opening/saving projects

* Edit Menu interacts with Ul elements. It
can be used to import Ul templates or
demos after project creation

» Help Menu redirects to official support

forum. Also contains Software License Help menu item in File Menu
Agreement
K” Documentation Link: File Menu

life.caugmented

34

The file menu is made of three elements/ File, edit and help menu items. The
File Menu is used for creating, editing and saving projects. A link to the official
forum is also given if in need of support or to ask questions.

Link to the forum “Community” :
https://community.st.com/s/topic/0TO0X0000003iw6WAA/touchgfx

34



Consists of a File, Edit and Help menu
items

* File Menu used for
creating/opening/saving projects

* Edit Menu interacts with Ul elements. It
can be used to import Ul templates or
demos after project creation

» Help Menu redirects to official support
forum. Also contains Software License
Agreement

S7i
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File Menu

File menu item in File Menu Edit menu item in File Menu

Help menu item in File Menu

Documentation Link: File Menu

35

File Menu is used for creating/opening/saving projects and exiting Designer

35



Consists of a File, Edit and Help menu
items

* File Menu used for
creating/opening/saving projects

* Edit Menu interacts with Ul elements. It
can be used to import Ul templates or
demos after project creation

» Help Menu redirects to official support
forum. Also contains Software License
Agreement

File Menu

File menu item in File Menu Edit menu item in File Menu

Help menu item in File Menu

Documentation Link: File Menu

36
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Consists of a File, Edit and Help menu
items

* File Menu used for
creating/opening/saving projects

* Edit Menu interacts with Ul elements. It
can be used to import Ul templates or
demos after project creation

» Help Menu redirects to official support
forum. Also contains Software License
Agreement

File Menu

File menu item in File Menu Edit menu item in File Menu

Help menu item in File Menu

Documentation Link: File Menu

37
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Images View

Used to manage images used in a
TouchGFX Project

* Images are located under the assets\images
folder in the project folder

Contains 3 sections: the tree view on the
left, the table view in the middle and the
properties view on the right

» Tree view: overview of the images and
folders

» Table view: list of images located in the
selected folder Image View of the Ul template “Demo 1”

* Properties view: properties of an image

‘YI Documentation Link: Images View 38
ife.

The images view is where users can add and edit the images needed for the
project. It consists of three columns.

38



Images View

Used to manage images used in a
TouchGFX Project

* Images are located under the assets\images
folder in the project folder

Contains 3 sections: the tree view on the
left, the table view in the middle and the
properties view on the right

» Tree view: overview of the images and
folders

» Table view: list of images located in the
selected folder Image View of the Ul template “Demo 1”

* Properties view: properties of an image

‘YI Documentation Link: Images View
ife.
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The tree view on the left which gives an overview of the images available and
in which folder they are stored.

39



Images View

Used to manage images used in a
TouchGFX Project

* Images are located under the assets\images
folder in the project folder

Contains 3 sections: the tree view on the
left, the table view in the middle and the
properties view on the right

» Tree view: overview of the images and
folders

» Table view: list of images located in the
selected folder Image View of the Ul template “Demo 1”

* Properties view: properties of an image

"I Documentation Link: Images View 40
ife.

The table view gives more information on the image used in the UI.

40



Images View

Used to manage images used in a
TouchGFX Project

* Images are located under the assets\images
folder in the project folder

Contains 3 sections: the tree view on the
left, the table view in the middle and the
properties view on the right

» Tree view: overview of the images and
folders

» Table view: list of images located in the
selected folder Image View of the Ul template “Demo 1”

* Properties view: properties of an image

‘YI Documentation Link: Images View 41
ife.

The properties view is where users can edit the properties of an image, like the
bit per pixel format or where they are stored in the board.
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Texts View

Used for configuration of texts,
translations and typographies

+ Single Use and Resources tabs both
contain an overview of texts but have s ‘
d |ﬁ:e re nt Usage Text View of the Ul template “Demo 1”

Working with texts and the Text Views is explained in the
“Texts and Fonts” article

"I Documentation Link: Texts View 42
ugmented
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The text view is where users can handle all the text used in the Ul. It is where
the fonts and typographies can be edited. Using texts can be complicated.
This section is explained in detail in the related articles in the documentation.
Texts and Fonts documentation link :
https://support.touchgfx.com/docs/development/ui-development/touchgfx-
engine-features/texts-and-fonts

Languages and Characters link :
https://support.touchgfx.com/docs/development/ui-development/touchgfx-
engine-features/languages-and-characters

42



Config View

Various settings affecting the project can
be configured in the Config View

» General settings
* Application name or startup screen

 Display setting

* Dimensions, display orientation and color
depth

+ Default image settings Config View

» Settings of all images in the project, unless
overwritten in the Images View

ST
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Documentation Link: Config View

43

The config view is where users can configure advanced settings for the
project, for example overwriting the compiling and flashing commands.
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Canvas View

» Landing screen after project creation

+ Visual representation of the selected screen
or custom container

* The left bar is where screens and
custom containers are configured

» Additional Screens/Custom containers
added by pressing the blue icon

» Screen and Widget order changed by
dragging

The Canvas View

Documentation Link: Canvas View 44

Screens and Widgets order changed by dragging them below or above others
in the tree

44



» Landing screen after project creation

+ Visual representation of the selected screen
or custom container

* The left bar is where screens and
custom containers are configured

» Additional Screens/Custom containers
added by pressing the blue icon

» Screen and Widget order changed by
dragging

Canvas View

The Canvas View

Documentation Link: Canvas View

45
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- “Add widget” button [E] opens the
widget menu

» Contains all available widgets grouped by
categories

 Clicking a widget will add it to the canvas

* The right bar contains two tabs:
Properties and Interaction

* Properties is where widgets and screen
properties are set

* Interaction is where widgets and screen
interactions can be created and defined

Canvas View

The Canvas View

Documentation Link: Canvas View

46

The add button widget will open the widget menu, where users can select

which widget to add to their Ul. Those widgets will be displayed in the canvas

view.

The size and position of the widgets can be manipulated by users within the
center section, representing the looks of the selected screen.

46



- “Add widget” button [E] opens the
widget menu

» Contains all available widgets grouped by
categories

 Clicking a widget will add it to the canvas

* The right bar contains two tabs:
Properties and Interaction

* Properties is where widgets and screen
properties are set

* Interaction is where widgets and screen
interactions can be created and defined

Canvas View

The Canvas View

Documentation Link: Canvas View

47

The right bar contains the properties and interaction tabs. This is where the
properties of screens and widgets are set, like there position and width and

height. The interaction tab is used to define widgets and screen interactions,

for example a fading in image when entering the main screen at startup

47



Interactions

* An Interaction consists of a trigger and
an action
« ATrigger is what will start the interaction

« An Action is what will happen after a Trigger PNFERACTIONS
has been emitted

» The number of triggers and actions available
depends on the widgets added to the project

* Interactions can be chained

Add Interaction

Interaction tab in TouchGFX Designer

Moving a widget when a button is pressed

&y
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Documentation Link: Interactions

48

Interactions are often the heart of an Ul. The interactions set within this tab in
TouchGFX designer will generate all the code necessary to have them
running. Users can add or modify the logic of the interactions through user
code to add more complex animations and interactions.
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Widgets
» Wide range of widgets available

» Categories based on properties and
usage

» Custom containers will appear as a new
category

» Custom widgets cannot be seen nor
configured from Designer

r Wiget tab
/4

Documentation Link: Custom Widgets 50
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The widget menu orders the widgets available in TouchGFX Designer by categories
based on their properties and usage; for example the different types of button
widgets are under a category called Buttons. Additional widgets maybe added with
futur releases. Clicking on an icon will add a widget with a name and initial settings to
the selected screen.

Creating Custom containers will spawn a new category at the bottom of the widget
menu, where they will made available. They can be used different scenarions and are
useful for advanced Uls. Some widgets like scroll list or scroll list needs custom
containers to function.

It is possible for users to create widgets through code for specific needs in a project.
However they will not be shown nor be configured in the canvas view of TouchGFX
Designer, but will be displayed in the simulator or on the board.

50



The button with label widget it is a widget aware of touch events. It is used as
a button, sending a callback wen released. It has two states: pressed and
released each associated with an image and text. The images should not look
the same, but need to of the same size, in order to graphically show the user if
the widget is pressed. As it does not involve complex animations or
calculations it is considered a light widget with good performances on most
MCUs.



Custom containers can be used for a wide range of application. The coordinates of
child elements are related to the container's coordinates, it is then useful for moving
multiple elements at once. It is also useful when having a recurrent group of
elements in different screens, like a menu bar consisting of three buttons with boxes
with text areas as shown on this slide. Depending on the widgets used within the
container the performances can vary.






Working with TouchGFX in User Code

 Actions and Triggers
» Custom interactions
* Interface between Designer and User Code
» Created under screen properties

« After creation, then added to the interaction
system

lite.augmented

Documentation Link: Custom Triggers and Actions
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Working with TouchGFX in User Code

 Triggers

» Enable a Screen to react on events from a Custom
Container
» Custom Container can emit a custom Trigger as an Action

« Enable a Screen to react to a custom Trigger from a
Custom Container

» Able to pass data from Custom Container to Screen
* Generated as C++ callback

 After creation, the trigger is added to the interaction
system

e Can be emitted from User Code

Lys
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Screen

Custom Container

Trigger
Fx. Button pressed
¥

Interaction System

Action
Emit custom trigger
b4

Trigger
Custom trigger happens

Interaction System

I4_

Action
Fx. Show text widget

4
e

‘Widget

Flow for a Custom trigger between a widget in a
custom container and a widget in a screen

Documentation Link: Custom Triggers and Actions
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Working with TouchGFX in

» Creating and using a Trigger

trigger!

AT T aTYGrY

ST
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Documentation Link: Custom Triggers and Actions

User Code

56
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Working with TouchGFX in User Code

 Triggers — Example
e Custom Container added to a Screen

* Pressing ON or OFF emits a ON or OFF
Custom Trigger

» Based on the Custom Trigger, the ON or OFF
text will show

Screen

Custom Container|

OFF

Documentation Link: Custom Triggers and Actions

57
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Working with TouchGFX in User Code

* Actions
 Interface between Screen/Custom Container and User
Code

* The Interaction System can call Custom Actions in User
Code as Actions

» User code can emit Custom Actions as Triggers via the
Interaction System

* Able to pass data from Screen or Custom Container to
User Code

» Generated as a virtual C++ methods
* The action is added to the interaction system

ST
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Screen

Trigger Action
Fx. Button pressed Fx. Update Text

Interaction System

Action Trigger
Call custom Action Emit custom Action

User Code

Relations between Widgets, Interactions System
and User Code, when using Custom Actions

Documentation Link: Custom Triggers and Actions
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Working with TouchGFX in User Code

« Actions: Designer Setup Example

"’ Documentation Link: Custom Triggers and Actions
od

59
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Working with TouchGFX in User Code

 Actions: User Code Example

ScreenlView.cpp & X ScreentView.hpp ScreeniView.cpp & X

= ScreeniView.setupScreen  ~ _ =% void ScreeniViewssetupSereen() = ScreeniView.actionl ~ _ 2 virtualvoid action()

creenlView(

ScreeniView: zacti

KYI Documentation Link: Custom Triggers and Actions
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Working with TouchGFX in User Code

e Actions: Demo

* When the slider is dragged, the value of the
slider is passed with an Action to User Code,
which updates the text in the box

* When the finger (mouse) releases the slider,
another action sends the confirmed value to
the User Code via an Action

* If the value is 100 a Custom Action is sent
from user code, to changes screen

Lys

life.augmented

Documentation Link: Custom Triggers and Actions
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Working with TouchGFX in User Code

e Mixins

Extend Widgets functionality

Mixin funtionalities are used in User Code
Four different Mixins

* Move Animator

* Fade Animator

* Draggable

* Click Listener

Can be added to a widget in the Designer
Container Widgets cannot use Fade Animator

ST

life.augmented

The Mixins properties in the TouchGFX Designer (top)
The Mixin Move Animator added to a Widget in User
Code (bottom)

Documentation Link: Mixins
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Working with TouchGFX in User Code

* Mixin — Example

» The four images, has the four =
Mixins added to them, denoted
by the text above them.

Move Animator  Fade Animator Click Listener Draggable
A ( A ( A ( ] (
y Y V] V|




User Code

Everything done in the Designer, can also be done in User Code
» But the Designer can help you with a lot of things

Avoid going back and forth between User Code and Generated Code
Remember to utilize the MVP Pattern

Inspect Generated code

Reuse code from examples

The TocuhGFX API: Button

KY’ Documentation Link: Model-View-Presenter Design Pattern
-
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» Generated Code from Animated Image Example

st touchgfx::AbstractButton& src)

Documentation Link: Code Structure

65

Here we see relation between the code that is generated and user code,
showing how to interact between user code and generated code.

The two screen shots are snippets of code from the base view, to the left, and
view to the right.

The code are from the Animated Image example and can be accessed from

the TouchGFX Designer.
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Where to go next?

* More information can be found in the Ul development section:
Ul Development

* Get started on Ul developing with the Hands-on Workshop:
Ul Development - Getting Started

 Or by following oure tutorials:

Tutorials
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For further support and content,
you can visit the TouchGFX online
documentation site
https://support.touchgfx.com

life.cugmented
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