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https://support.touchgfx.com/docs/resources/presentations
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Introduction

With this presentation, you get a fundamental knowledge
about TouchGFX Ul Development. You will learn:

* The basics of the software architecture
+ Getting started working with the Designer and its Ul components
» Discovering TouchGFX Engine features



Introduction

Further reading
*Go to the TouchGFX documentation site :

http://support.touchgfx.com/

Slides in this workshop will refer to relevant documentation pages. Links will be in
the lower corner of the slides

*A good place to start reading following this workshop is:

Ul Development Introduction



http://support.touchgfx.com/
https://support.touchgfx.com/docs/development/ui-development/ui-development-introduction

Introduction

TouchGFX Development

TouchGFX

Main components: Ul Application

Main activities: ul

Development

In this presentation, we will focus on the Ul development activity

We go deeper into the different activities in the other presentations

‘ 'l Documentation Link: Development Introduction 5
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https://support.touchgfx.com/docs/development/development-introduction

Software architecture




Software architecture

* Model-View-Presenter (MVP)
* View
* Model

Backend System TouchGFX Ul
* Presenter

resenter

« Separation

. . Model User
® Un|t teStIng Changed Event
Update Update
* Decoupled code Extemnal Model ul

Event

Backend Module ; m
 —
ul

Event

‘ ’ l Documentation Link: Model-View-Presenter Design Pattern 7
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https://support.touchgfx.com/docs/development/ui-development/software-architecture/model-view-presenter-design-pattern

Software architecture

* View
» Creation of Ul elements
* Ul element manipulation
. ., _ Backend System TouchGFX UI
» “Reception” of user input

» Sending of user input to

» Update of Ul based on data from Mode 2 User
Presenter g odote | Update Fvent
t vlerna » [ ¥ - Ul
e

Documentation Link: Model-View-Presenter Design Pattern 8



https://support.touchgfx.com/docs/development/ui-development/software-architecture/model-view-presenter-design-pattern

Software architecture

 Presenter

 Mediator between Model and
View

« Receives data from the Model sechend System TouchGFX Ul
and prepares it for the View
* Receives input from the View Presen ter

and sends it to the Model

* Business logic for Ul Model User
Changed Uodate date Event
* No knowledge about Ul aterna Mode

‘ ’ l Documentation Link: Model-View-Presenter Design Pattern 9
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https://support.touchgfx.com/docs/development/ui-development/software-architecture/model-view-presenter-design-pattern

Software architecture

 Model

« Communicates with the
backend

o Stores data
 Passes data to the Presenter

Backend System TouchGFX Ul

Model . P
Changed [
Update pelate
External Model
.

Event

Backend Module

Eve nt

"l Documentation Link: Model-View-Presenter Design Pattern 10
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https://support.touchgfx.com/docs/development/ui-development/software-architecture/model-view-presenter-design-pattern

Software architecture

« MVP — Example

 When update is pressed, a get time request
Is sent to the Model via the Presenter

* The Model sends time data to the Presenter

e The Presenter converts the data into
something the Clock widget can use and
sends it to the View

* The View updates the Clocks with the new
data

-Update Clock.

‘ 'l Documentation Link: Model-View-Presenter Design Pattern 11
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https://support.touchgfx.com/docs/development/ui-development/software-architecture/model-view-presenter-design-pattern

* The Screen Concept

Application consists of a number of
“Screens”

Logical grouping of Ul and Ul logic

One View class and one Presenter class
One active screen at the time

Minimizes the amount of RAM-memory

Lys
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Software architecture

Screen 3

"

Screen 1

.
| Screen 2

F :
<

Update
Ul

Fa :
"

Presenter

User
Event

A

Update
Model

Model
Changed

lllustration of the screen concept with screen 1 as the active screen

Documentation Link: The Screen Concept

12



https://support.touchgfx.com/docs/development/ui-development/software-architecture/screen-definition-and-mvp

Software architecture

B o o P owee, Caeust Lampie e o &

« Screen Concept: Example

 When selecting clock mode, in the
“settings” screen, the selected mode is
stored in the model

* When pressing update, the Clock also
retrieves the clock mode from the model

"l Documentation Link: The Screen Concept 13
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https://support.touchgfx.com/docs/development/ui-development/software-architecture/screen-definition-and-mvp

Software architecture

 Generated Code vs. User

Code
* Engine
» Provided by TouchGFX
» Generated e cation

« Generated by the Designer
multiple times

» Code for the widgets added in
the Designer

* Regenerated often

« User
» Generated by the Designer once
« Created for handwritten code

"l Documentation Link: Code Structure 14
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https://support.touchgfx.com/docs/development/ui-development/software-architecture/code-structure

Software architecture

* Rotating Circle Example: The Designer

Bl GeneratedCodeExample - TouchGFX Designer - 415.0 R —-

File Edit Help

TouchGF:! pesioner

"l Documentation Link: Code Structure 15
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https://support.touchgfx.com/docs/development/ui-development/software-architecture/code-structure

Software architecture

« Rotating Circle Example: The generated code

ScreenlViewBase

K’l Documentation Link: Code Structure 16
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https://support.touchgfx.com/docs/development/ui-development/software-architecture/code-structure

Software architecture

» Rotating Circle Example: The User Code

K’l Documentation Link: Code Structure 17
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https://support.touchgfx.com/docs/development/ui-development/software-architecture/code-structure

Software architecture

» Rotating Circle Example: The Demo

"l Documentation Link: Code Structure 18
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https://support.touchgfx.com/docs/development/ui-development/software-architecture/code-structure

Working with TouchGFX Designer




A Widget is an abstract definition of
something that can be drawn on the
screen and be interacted with

 Numerous standard widgets available
» Customizable from Designer and Code

« The adding order determines the display
order

* Possible to create custom widgets

Ly
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Widgets

E] ButtonExample

A Button widget with an Image widget as a background

Documentation Link: Widgets

20



https://support.touchgfx.com/docs/development/ui-development/working-with-touchgfx/widgets-and-containers

A Container is a component that contains child
nodes

« Children can be widgets or other containers
» Position of widgets defined relatively to the parents

» Widgets are added to a container by
dragging widgets into the container in the
tree view

« Containers act as viewports

* Only the parts of the children that intersect with the
geometry of the container are visible

S7
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Containers

[ _ ]

L3 T |

A container acting as a view port

Documentation Link: Containers 21



https://support.touchgfx.com/docs/development/ui-development/working-with-touchgfx/widgets-and-containers

TouchGFX includes a simulator for Ul
testing

* Building and running on target can be
time-consuming

* You can run the simulator in 3 ways
by use of:

» TouchGFX Designer
 TouchGFX Environment
* Visual Studio

« Option to create User code that

only runs when using the simulator
> /4
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File Edit Help
TouchGF3{ pesiner

Simulator

Bird Eat Coin
Play the Bird Eat Coin game
Shows graphics performance of TouchGFX

Launching the simulator from TouchGFX Designer

Documentation Link: Simulator

22



https://support.touchgfx.com/docs/development/ui-development/working-with-touchgfx/simulator

Compiling

A TouchGFX application can be compiled for the PC simulator or for the target
hardware

« PC simulator: Projects compiled using GCC or Visual Studio

« Hardware target: Projects compiled with the active toolchain
 Active toolchain set in CubeMX

Ly
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Documentation Link: Compiling 23



https://support.touchgfx.com/docs/development/ui-development/working-with-touchgfx/compiling-and-flashing

Flashing

Flashing projects on STM32-based boards can be done with different toolchains.

 Building generates a binary (.hex or .elf)
* Flash with STlink or STM32Cube Programmer

* Running on target is done using GCC
« Command can be overridden in configurations

K’l Documentation Link: Flashing 24
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https://support.touchgfx.com/docs/development/ui-development/working-with-touchgfx/compiling-and-flashing

Debugging

A TouchGFX project is a set of C++ files generated by TouchGFX Designer,
TouchGFX Generator and written by developers

» Can be debugged as any other C++ application

» Target debugging with an IDE

» Performance testing

« Simulator Debugging

» Faster process than on target

» Using the DebugPrinter

* Prints debug messages on the display

Ly
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Documentation Link: Debugging 25



https://support.touchgfx.com/docs/development/ui-development/working-with-touchgfx/debugging

Getting started

Using Ul templates is a good way to start a project or to understand how to work
with widgets and TouchGFX

« Widget showcasing

« Complete demos

» Can be used as source of inspiration

Online applications are out-of-the box applications dedicated to an ST evaluation kit

* More complex than Ul templates
» Explore different features of the TouchGFX framework
» Can include sample integration with hardware

K’l Documentation Link: Examples 26
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https://support.touchgfx.com/docs/development/ui-development/working-with-touchgfx/examples

Designer user guide




Startup Window

TouchGF:{ cesioner x

This is where new projects can be
COnflgured and Created Create New Application Recent Applications

I et a
°
» Possibility to work with the Simulatoror . -
with an Application or Ul template = = o
CCCCCCCCCC °
B - = = o
«=D o
o

Startup window when opening TouchGFX Designer

"l Documentation Link: Startup Window 28
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https://support.touchgfx.com/docs/development/ui-development/designer-user-guide/startup-window

Startup Window

TouchGF:{ cesioner x

This is where new projects can be
COnflgured and Created Create New Application Recent Applications

 Possibility to work with the Simulator or
with an Application or Ul template

000000O0O0

Startup window when opening TouchGFX Designer

"l Documentation Link: Startup Window 29
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https://support.touchgfx.com/docs/development/ui-development/designer-user-guide/startup-window

Contains a Navigation Bar, Command
Buttons, Notification Bar, and a Detailed

log

* Navigation bar
« Canvas: drag and drop application building
« Images: management of images used
« Text: management of text and typographies
» Config: configuration of project settings

Ly
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Main Window

The main window options

Documentation Link: Main Window

30



https://support.touchgfx.com/docs/development/ui-development/designer-user-guide/main-window

Main Window

Contains a Navigation Bar, Command
Buttons, Notification Bar, and a Detailed

log

* Navigation bar
« Canvas: drag and drop application building
« Images: management of images used
« Text: management of text and typographies
» Config: configuration of project settings

The main window options

"l Documentation Link: Main Window 31
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https://support.touchgfx.com/docs/development/ui-development/designer-user-guide/main-window

Main Window

* Project can be run on target or on PC
simulator

« Both commands trigger assets, code
generation and compiling

« Key shortcuts are respectively “F5” and “F6”

 Notification bar and Detailed log are at
the bottom of the Main Window

« Shows status of running command

« Opens log of last command
« Can be toggled with keys “Alt” + “L”

Running and generating code commands, Navigation bar and Browser Code positions

"l Documentation Link: Main Window 32
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https://support.touchgfx.com/docs/development/ui-development/designer-user-guide/main-window

Main Window

* Project can be run on target or on PC
simulator

« Both commands trigger assets, code
generation and compiling

« Key shortcuts are respectively “F5” and “F6”

 Notification bar and Detailed log are at
the bottom of the Main Window

« Shows status of running command

« Opens log of last command
« Can be toggled with keys “Alt” + “L”

Running and generating code commands, Navigation bar and Browser Code positions

"l Documentation Link: Main Window 33
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https://support.touchgfx.com/docs/development/ui-development/designer-user-guide/main-window

File Menu

Consists of a File, Edit and Help menu
items

g Flle Menu used for File menu item in File Menu Edit menu item in File Menu
creating/opening/saving projects

« Edit Menu interacts with Ul elements. It
can be used to import Ul templates or
demos after project creation

« Help Menu redirects to official support
forum. Also contains Software License Help men item in File Menu
Agreement

K’l Documentation Link: File Menu 34
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https://support.touchgfx.com/docs/development/ui-development/designer-user-guide/file-menu

File Menu

Consists of a File, Edit and Help menu Dz
items
g Flle Menu used for File menu item in File Menu Edit menu item in File Menu

creating/opening/saving projects

« Edit Menu interacts with Ul elements. It
can be used to import Ul templates or
demos after project creation

« Help Menu redirects to official support
forum. Also contains Software License Help men item in File Menu
Agreement

K’l Documentation Link: File Menu 35
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https://support.touchgfx.com/docs/development/ui-development/designer-user-guide/file-menu

File Menu

Consists of a File, Edit and Help menu
items

g Flle Menu used for File menu item in File Menu Edit menu item in File Menu
creating/opening/saving projects

« Edit Menu interacts with Ul elements. It
can be used to import Ul templates or
demos after project creation

« Help Menu redirects to official support
forum. Also contains Software License Help men item in File Menu
Agreement

K’l Documentation Link: File Menu 36
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https://support.touchgfx.com/docs/development/ui-development/designer-user-guide/file-menu

File Menu

Consists of a File, Edit and Help menu
items

g Flle Menu used for File menu item in File Menu Edit menu item in File Menu
creating/opening/saving projects

« Edit Menu interacts with Ul elements. It
can be used to import Ul templates or
demos after project creation

« Help Menu redirects to official support
forum. Also contains Software License Help men item in File Menu
Agreement

K’l Documentation Link: File Menu 37
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https://support.touchgfx.com/docs/development/ui-development/designer-user-guide/file-menu

Images View

Used to manage images used in a
TouchGFX Project

« Images are located under the assets\images
folder in the project folder

Contains 3 sections: the tree view on the
left, the table view in the middle and the
properties view on the right

« Tree view: overview of the images and
folders

« Table view: list of images located in the
selected folder Image View of the Ul template “Demo 1”

* Properties view: properties of an image

"l Documentation Link: Images View 38
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https://support.touchgfx.com/docs/development/ui-development/designer-user-guide/images-view

Images View

Used to manage images used in a
TouchGFX Project

« Images are located under the assets\images
folder in the project folder

Contains 3 sections: the tree view on the
left, the table view in the middle and the
properties view on the right

« Tree view: overview of the images and
folders

« Table view: list of images located in the
selected folder Image View of the Ul template “Demo 1”

* Properties view: properties of an image

"l Documentation Link: Images View 39
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https://support.touchgfx.com/docs/development/ui-development/designer-user-guide/images-view

Images View

Used to manage images used in a
TouchGFX Project

« Images are located under the assets\images
folder in the project folder

Contains 3 sections: the tree view on the
left, the table view in the middle and the
properties view on the right

« Tree view: overview of the images and
folders

« Table view: list of images located in the
selected folder Image View of the Ul template “Demo 1”

* Properties view: properties of an image

"l Documentation Link: Images View 40
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https://support.touchgfx.com/docs/development/ui-development/designer-user-guide/images-view

Images View

Used to manage images used in a
TouchGFX Project

« Images are located under the assets\images
folder in the project folder

Contains 3 sections: the tree view on the
left, the table view in the middle and the
properties view on the right

« Tree view: overview of the images and
folders

« Table view: list of images located in the
selected folder Image View of the Ul template “Demo 1”

* Properties view: properties of an image

"l Documentation Link: Images View 41
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https://support.touchgfx.com/docs/development/ui-development/designer-user-guide/images-view

Texts View

Used for configuration of texts,
translations and typographies

» Single Use and Resources tabs both
contain an overview of texts but have B S s
d |ﬁ:e re nt u Sag e Text View of the Ul template “Demo 1”

Working with texts and the Text Views is explained in the
“Texts and Fonts” article

"l Documentation Link: Texts View 42
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https://support.touchgfx.com/docs/development/ui-development/touchgfx-engine-features/texts-and-fonts
https://support.touchgfx.com/docs/development/ui-development/designer-user-guide/texts-view

Config View

Various settings affecting the project can
be configured in the Config View

* General settings
» Application name or startup screen

* Display setting

« Dimensions, display orientation and color
depth

 Default image settings config View

« Settings of all images in the project, unless
overwritten in the Images View

S7
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Documentation Link: Config View 43



https://support.touchgfx.com/docs/development/ui-development/designer-user-guide/config-view

Canvas View

« Landing screen after project creation

* Visual representation of the selected screen
or custom container

* The left bar is where screens and
custom containers are configured

* Additional Screens/Custom containers
added by pressing the blue icon

« Screen and Widget order changed by
dragging

The Canvas View

Ly
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Documentation Link: Canvas View 44



https://support.touchgfx.com/docs/development/ui-development/designer-user-guide/canvas-view

Canvas View

« Landing screen after project creation

* Visual representation of the selected screen i
or custom container

* The left bar is where screens and
custom containers are configured

* Additional Screens/Custom containers
added by pressing the blue icon

« Screen and Widget order changed by
dragging

The Canvas View

Ly
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Documentation Link: Canvas View 45



https://support.touchgfx.com/docs/development/ui-development/designer-user-guide/canvas-view

Canvas View

» “Add widget” button opens the
widget menu

« Contains all available widgets grouped by
categories

 Clicking a widget will add it to the canvas

* The right bar contains two tabs:
Properties and Interaction

* Properties is where widgets and screen
properties are set

 Interaction is where widgets and screen
interactions can be created and defined

The Canvas View

Ly
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Documentation Link: Canvas View 46



https://support.touchgfx.com/docs/development/ui-development/designer-user-guide/canvas-view

Canvas View

» “Add widget” button opens the
widget menu

« Contains all available widgets grouped by
categories

 Clicking a widget will add it to the canvas

* The right bar contains two tabs:
Properties and Interaction

* Properties is where widgets and screen
properties are set

 Interaction is where widgets and screen
interactions can be created and defined

The Canvas View

Ly
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Documentation Link: Canvas View 47



https://support.touchgfx.com/docs/development/ui-development/designer-user-guide/canvas-view

Interactions

* An Interaction consists of a trigger and
an action
« ATrigger is what will start the interaction

* An Action is what will happen after a Trigger INTERACTIONS
has been emitted

Add Interaction

« The number of triggers and actions available
depends on the widgets added to the project

* |nteractions can be chained

Interaction tab in TouchGFX Designer

Moving a widget when a button is pressed

S7

Documentation Link: Interactions 48
life.augmented



https://support.touchgfx.com/docs/development/ui-development/designer-user-guide/interactions-view

Ul components




Widgets

» Wide range of widgets available

« Categories based on properties and
usage

» Custom containers will appear as a new
category

SHAPES

« Custom widgets cannot be seen nor - = 2K
configured from Designer

’l Documentation Link: Custom Widgets 50
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https://support.touchgfx.com/docs/development/ui-development/touchgfx-engine-features/custom-widgets

Button with Label widget

BUTTONS

» Widget aware of touch events
» Sends a callback when released
* Found in “Buttons” widget group

° “Pressed” and “Released” States ButtonWithLabel In TouchGFX Designer
« Each associated with an image and a text B ButtontithLabeExample - x
 Trigger source: “Button is clicked
ButtonWithLabel widget running in the simulator
‘,’ Documentation Link: Button With Label o1
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https://support.touchgfx.com/docs/development/ui-development/ui-components/buttons/button-with-label

Custom container

« Wide range of application
« Up to the user's needs

* Performances dependent on the
complexity of the child nodes

« Example: menu bar needed for all the
screens of an application

Custom container widget configuration

Ly
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Documentation Link: Custom Containers 52



https://support.touchgfx.com/docs/development/ui-development/touchgfx-engine-features/custom-containers/

Working with TouchGFX in User Code




Working with TouchGFX in User Code

* Actions and Triggers
» Custom interactions
 Interface between Designer and User Code
» Created under screen properties trigger

« After creation, then added to the interaction
system

Mame

triggerl

Description

Documentation Link: Custom Triggers and Actions 54
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https://support.touchgfx.com/docs/development/ui-development/touchgfx-engine-features/custom-triggers-and-actions

Working with TouchGFX in User Code

Screen

* Triggers
Custom Container
» Enable a Screen to react on events from a Custom
Container R
« Custom Container can emit a custom Trigger as an Action FK.BUL”a}géiessed
« Enable a Screen to react to a custom Trigger from a
Custom Container o
« Able to pass data from Custom Container to Screen B el

Trgger
Custom trigger happens

 Generated as C++ callback

 After creation, the trigger is added to the interaction Interaction System
system

e Can be emitted from User Code

Action
P, Show text widget

Widget

I

Flow for a Custom trigger between a widget in a
custom container and a widget in a screen

"l Documentation Link: Custom Triggers and Actions 55
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https://support.touchgfx.com/docs/development/ui-development/touchgfx-engine-features/custom-triggers-and-actions

Working with TouchGFX in User Code

* Creating and using a Trigger

S7
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TRIGGERS

triggerl

bool

Mame

triggerl

Description

Interaction

Trigger

Button is clicked

Choose clicked source

buttonl

virtual function
Chan een

Emit triggerl

Exed

Fads Emit tri

Wait for
FALILY ITTVET G LIRarn

Interaction

Trigger
Button is dlicked

Ch cked source
buttonl

Action
Emit trigger! (ool

Value | bool

fa EI

Interaction Name

Interaction

Interaction

Trigger

stomContainer] trigger] happer -

omponent

customContaineril

Action

Interaction Name

Interaction

Documentation Link: Custom Triggers and Actions

56



https://support.touchgfx.com/docs/development/ui-development/touchgfx-engine-features/custom-triggers-and-actions

Working with TouchGFX in User Code

* Triggers — Example

e Custom Container added to a Screen

* Pressing ON or OFF emits a ON or OFF &
Custom Trigger

« Based on the Custom Trigger, the ON or OFF
text will show

Screen Custom Container

OFF

Documentation Link: Custom Triggers and Actions 57
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https://support.touchgfx.com/docs/development/ui-development/touchgfx-engine-features/custom-triggers-and-actions

Working with TouchGFX in User Code

* Actions
* Interface between Screen/Custom Container and User e
Code
» The Interaction System can call Custom Actions in User MT
Code as Actions o P Ui Tox
« User code can emit Custom Actions as Triggers via the |
Interaction System Interaction System
» Able to pass data from Screen or Custom Container to N TT
User Code CaIIcusfolr?wnAction Emit cugtgogn:rAction
» Generated as a virtual C++ methods o
« The action is added to the interaction system

Relations between Widgets, Interactions System
and User Code, when using Custom Actions

"l Documentation Link: Custom Triggers and Actions 58
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https://support.touchgfx.com/docs/development/ui-development/touchgfx-engine-features/custom-triggers-and-actions

Working with TouchGFX in User Code

 Actions: Designer Setup Example

Interactiond Interaction]

actionl

Trigger

MName
actionl actionl is called

Hardware button is clicked

Screen is entered

Call new virtual function

Call 5creent actionl
Change z

Wait f Interaction Name
interactiont Interactiond

S7
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Documentation Link: Custom Triggers and Actions 59



https://support.touchgfx.com/docs/development/ui-development/touchgfx-engine-features/custom-triggers-and-actions

Working with TouchGFX in User Code

* Actions: User Code Example

View.cpp

v

View.hpp Screen1View.cpp & X

ScreenlView.hpp & X Screenld Screen’

ScreenlView.cpp & X

=2 Screenl1Vi = Screen1View.actionl

- - . - - . -
=2 Screen1View = . =* class ScreenlView : public Screen1ViewBase

ScreenlView()

enlView::

creenlViewBase: : s

creenlView: :

eenlViewBase: :t

ScreenlView: :act

K’l Documentation Link: Custom Triggers and Actions 60
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https://support.touchgfx.com/docs/development/ui-development/touchgfx-engine-features/custom-triggers-and-actions

Working with TouchGFX in User Code

 Actions: Demo

* When the slider is dragged, the value of the
slider is passed with an Action to User Code,
which updates the text in the box

* When the finger (mouse) releases the slider,
another action sends the confirmed value to
the User Code via an Action

e If the value is 100 a Custom Action is sent
from user code, to changes screen

"l Documentation Link: Custom Triggers and Actions 61
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https://support.touchgfx.com/docs/development/ui-development/touchgfx-engine-features/custom-triggers-and-actions

Working with TouchGFX in User Code

* Mixins
« Extend Widgets functionality
« Mixin funtionalities are used in User Code
* Four different Mixins
* Move Animator
* Fade Animator
e Draggable
* Click Listener
« Can be added to a widget in the Designer
« Container Widgets cannot use Fade Animator The Mixins properties in the TouchGFX Designer (top)

The Mixin Move Animator added to a Widget in User
Code (bottom)

touchgfx: :MoveAnimator< touchgfx::Box > box;

"l Documentation Link: Mixins 62
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https://support.touchgfx.com/docs/development/ui-development/touchgfx-engine-features/mixins

Working with TouchGFX in User Code

* Mixin — Example

« The four images, has the four
Mixins added to them, denoted
by the text above them.

Move Animator Fade Animator Click Listener Draggable
K4 K4 K9 K¢
y ] Y V] Y

63




User Code

Everything done in the Designer, can also be done in User Code
« But the Designer can help you with a lot of things

Avoid going back and forth between User Code and Generated Code

Remember to utilize the MVP Pattern

Inspect Generated code

Reuse code from examples
The TocuhGFX API: Button

K’l Documentation Link: Model-View-Presenter Design Pattern 64
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https://support.touchgfx.com/docs/api/classes/classtouchgfx_1_1_button
https://support.touchgfx.com/docs/development/ui-development/software-architecture/model-view-presenter-design-pattern

* Generated Code from Animated Image Example

AbstractButt

BITMAP

ANI_14 I
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https://support.touchgfx.com/docs/development/ui-development/software-architecture/code-structure

Where to go next?

* More information can be found in the Ul development section:
Ul Development

« Get started on Ul developing with the Hands-on Workshop:
Ul Development - Getting Started

 Or by following oure tutorials:

Tutorials
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https://support.touchgfx.com/docs/development/ui-development/ui-development-introduction
https://support.touchgfx.com/docs/resources/presentations#ui-development---getting-started
https://support.touchgfx.com/docs/tutorials/tutorial-01

Thank you
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For further support and content,

you can visit the TouchGFX online
documentation site
https://support.touchgfx.com
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https://support.touchgfx.com/docs/introduction/welcome/

